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Overview 
Introducing InstantRecovery 
Thank you for purchasing or evaluating InstantRecoveryTM

If a critical OS or application file becomes corrupted, or Windows will not boot the user is left to 
recover the system using traditional methods. This ranges from implementing a pre-determined 
recovery procedure from whatever backup strategy exists, to a complete reload of the OS and all 
of the current updates, applications, settings, data, and etc. Time to recover the system varies 
with the method used, and generally ranges from 4-hours to a day. 

, the fastest means of 
recovering a failed system when the cause is associated with critical software 
corruptions. Almost every computer user has experienced a "Blue Screen" failure of the 
Windows Operating System (OS). Oftentimes, a simple re-boot will cure the problem; 
however, this is not always the case.  

With InstantRecovery, system recovery is almost immediate. After installation and creation of an 
alternate snapshot of the system, a InstantRecovery pre-Windows boot user interface can be 
invoked by pressing a hotkey (the default is 'F1') prior to its time-out. Inside this user interface is 
a listing of all pre-recorded snapshots that were taken from within Windows. After installation, 
you will see your original system image and the first copy of that image made during setup. 
Selection of the alternate (backup) snapshot is available, and the system will proceed to boot 
from this newly created snapshot. This procedure is all that is needed to recover the system 
should your current system image fail. After installation is completed, you may create up to ten 
system image snapshots from within the InstantRecovery Windows operating system user 
interface. 

In summary, InstantRecovery is a productivity tool, since it significantly reduces the Mean Time 
To Recover (MTTR) a failed system. It enables the end user to continue using their computer, 
and IT staff to quickly repair system crashes, rather than spend time on rebuilding. In this 
context, it is a "high availability" product. InstantRecovery can immediately determine if the 
problem with the failed system is hardware rather than software related. 

Copyright © Raxco Software, Inc. All rights reserved. InstantRecovery is a trademark of Raxco Software, Inc. All 
other names are trademarks or registered trademarks of their respective owners. 

Product Features 

 

The primary feature of InstantRecovery is its ability to immediately recover from a 
software related failure of a system with a simple reboot. 

Other features include: 
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Ability to create and maintain up to 10 "point-in-time" system snapshots. Each snapshot is 
bootable with no rebuild required.    
   
InstantRecovery Home Edition is limited to 5 snapshots. 

 

Differential (changed files only) copy engine for fast snapshot updates. 

 

Data Anchoring feature makes data files available to any snapshot that is booted. 

 

Ability to archive snapshots to another device, i.e. partition, disk drive, network location. 
Archives, although not immediately bootable, safeguard the OS and Applications in case 
of disk hardware failure. 

 

Ability to export and import archives to multiple files for storage on CD/DVD media. 

 

Password-protected snapshot groups; to restrict snapshot users.    
   
This feature is only found in the Business editions of InstantRecovery. 

 

Capability to return (freeze) the system to the same state every time the system boots.    
   
This feature is only found in the Business editions of InstantRecovery. 

 

Scheduling of snapshot or archive updates. 

 

Simple installation without the need to create additional partitions or other modifications to 
the system. 

 

For situations where Microsoft's VSS is not preferred, a proprietary open file technology; 
allows the creation of true point-in-time snapshots of the system volume, even if files are 
in use. 

 

Support for Microsoft BitLocker disk encryption. 

System Requirements 
InstantRecovery Desktop/Laptop Requirements: 

• 32-bit and 64-bit versions of Windows 10, Windows 8, Windows 8.1, Windows 7, 
Windows Vista or Windows XP. 

• Available Hard Disk Space: 6 MB for application, additional space required for 
snapshots will vary* 

• NTFS file system** 

InstantRecovery Server Requirements: 

• Windows Server 2012, Windows Server 2012 R2, Windows Server 2008, 
Windows Server 2008 R2 or Windows Server 2003. 
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• Available Hard Disk Space: 6 MB for application, additional space required for 
snapshots will vary* 

• NTFS file system** 

* Additional hard drive space is required for each snapshot. Ex: To snapshot a 2 GB 
operating system and applications, an additional 2 GB (system disk) is required for the 
snapshot for a 4 GB requirement total.  Bootable Recovery Snapshots are stored on the 
C:\ drive (the drive where Windows is installed).  Bootable Recovery Snapshots can not 
be stored on other drives. 
 
** Not compatible with FAT16, FAT32, ReFS or Dynamic Disks.  GPT disks supported 
in V2.1 Build 106 and newer.  

InstantRecovery recommended system requirements for best performance: 

• Multi processor CPU 
• 2GB RAM 
• 100GB+ hard drive 
• SATA (also know as Serial Advanced Technology Attachment) hard drive for 

desktops 
• SAS (also known as Serial Attached SCSI) hard drive for servers 

Notes about Microsoft BitLocker 
InstantRecovery supports Microsoft BitLocker by moving the pre-boot operations to the same 
place that check disk runs. That is after the BitLocker has unlocked the disk but before the 
operating system starts. 

There are some necessary restrictions: 

• You must setup BitLocker and encrypt your disk before installing 
InstantRecovery.  

• Before decrypting your disk you must completely uninstall InstantRecovery. You 
can reinstall InstantRecovery afterward.  

• All snapshots should be clones of the original encrypted volume. This is because 
the encryption is specific to the original volume. Any snapshot that is not a clone 
of the original encrypted volume will fail to boot.  

• Create Empty Snapshot is disabled if the volume is encrypted with BitLocker. 
The purpose of this feature was to allow a separate OS to be installed in the 
empty snapshot. However, this cannot be done on an encrypted volume. An 
empty snapshot can still be created with the CLI.  

Notes about Windows Vista and Later 
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InstantRecovery has the capability to create and maintain Snapshots and Archives for different 
versions of Microsoft Windows. With care, you can mix and match with different Microsoft 
operating systems. You can have Windows XP, and Windows Vista or later snapshots, with the 
ability to boot from one to another, all while retaining access to the same data files. Depending 
on how you use the technology, it can provide interesting and significant capabilities to a variety 
of users. 

The Bootstrap and Vista 

The first 16 sectors of the boot partition is the Bootstrap. The Bootstrap loads and starts the 
Windows operating system loader. The Bootstrap for Windows Vista is different from the 
Bootstrap for Windows XP. The Vista Bootstrap runs BOOTMGR while the XP Bootstrap runs 
NTLDR. 

Since all InstantRecovery snapshots share the same partition, the Bootstrap must be the same. 
However, there is a solution. If there is a copy of NTLDR named BOOTMGR, then the 
Bootstrap will work for XP 

InstantRecovery automates the process and will use the correct Bootstrap and make the copy of 
NTLDR as needed. Note that the copy of NTLDR named BOOTMGR is not deleted from the XP 
snapshot for safety's sake 

Data Anchoring and Vista 

Windows Vista does not use "Documents and Settings" for the user folders. Instead it uses a new 
folder named "Users". There is a hard link from "Documents and Settings" to "Users". 
InstantRecovery cannot anchor a file whose name contains a hard link. 

So, if you have anchored files or folders under "Documents and Settings" (e.g. a user's My 
Documents, Favorites, etc.), they will not be in the expected location under Vista. 

A solution is to create a common root folder, like \My Shared Data, place all data folders within 
this "master" data folder location, and anchor the \My Shared Data folder in order to share any 
data between snapshots. In a domain environment, My Documents is typically located on a file 
server, and thus no Data Anchoring required. 
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Getting Started 
Getting Started 
InstantRecovery represents a breakthrough in the time it takes to recover from any form of 
software corruption.  InstantRecovery snapshots your operating system, applications and selected 
data files and keeps them locally in a hidden and protected folder.  In the event of a system 
corruption from failed system or application updates, malware or a bad driver installation/update, 
you can invoke Instant Recovery and have your system restored in the time it takes to reboot.  

InstantRecovery works for both servers and workstations.  

NOTE:  InstantRecovery is going to make an exact copy of your system.  Before proceeding 
you need to make sure your system is in a state that you want to preserve.  

When you install InstantRecovery a wizard will walk you through the steps to create a Secondary 
snapshot and to Data Anchor any files (we recommend Anchoring the” My Documents” folder). 
The amount of time to create the snapshot is dependent on the amount of data to be copied.  A 
typical Windows operating system with installed applications is about 25GB so the initial copy 
can take some time.  The Primary snapshot is created by the installer and it is your source 
snapshot; the Secondary snapshot is the destination and it will be your recovery snapshot.  The 
Secondary snapshot is an exact copy of your system net of any temporary files or Data Anchored 
files.  Upon completion, the InstantRecovery main screen will show both a Primary and a 
Secondary snapshot in the Snapshots folder. The Primary snapshot will be highlighted with a 
blue triangle indicating it is the active snapshot.  At this point you can optionally boot into your 
Secondary snapshot.  Simply reboot the system and press the F1 key.  You will see 
InstantRecovery appear on the black screen during the boot process.  Use the arrow key to point 
to the Secondary snapshot and hit Enter. When the system reboots the InstantRecovery main 
screen will show the blue active snapshot arrow pointing at the Secondary snapshot.  

How To Test 

To test InstantRecovery we suggest installing Windows updates on the active Primary snapshot 
and note which updates have been applied.  Once complete, do a restart, boot into the Secondary 
snapshot and go to Control Panel. Click on “Programs and Features” and then click View 
Installed Updates on the left side. If you check the installed date you will see that the updates 
made to the Primary snapshot are not on the Secondary snapshot.   In InstantRecovery go to 
Actions and click on Copy/Update.  In the wizard select the Primary snapshot as the source and 
the Secondary snapshot as the destination. InstantRecovery will copy any changes from the 
Primary to the Secondary.  When it completes you can check the Control Panel on the Secondary 
snapshot and see that the updates have been made.  
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Concepts 
Introduction to Snapshots 
The most important InstantRecovery concept to understand is Snapshots.  

• InstantRecovery Snapshots are independent bootable images of your system drive.  
• You can have up to 10 snapshots. (5 snapshots for the Home edition of InstantRecovery) 
• Only one snapshot can be active at a time.  

For example, suppose you have three snapshots named Alpha, Beta and Gamma. Your System 
Drive (for example, Drive C) could be represented like this:  

System Drive 

 

At this time: 

• Snapshot Alpha is active.  
• Snapshot Alpha can increase in size up to the amount of available disk space.  
• Snapshots Beta and Gamma are not affected by what happens to Alpha.  

Now suppose you booted snapshot Gamma, then your System Drive would look like this:  
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System Drive 

 

A key point to note is that each snapshot is independent of the others. Changes in one snapshot 
do not affect the others. If you were to get a virus while Gamma was active, it will not infect 
Alpha or Beta. 

Creating Snapshots 

After installing InstantRecovery, your System Drive contains a single snapshot:  

System Drive 

 

You create a new snapshot by copying an existing snapshot. If you were to create Secondary 
snapshot by copying Primary snapshot, your System Drive would look like this: 
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System Drive 

 

Secondary snapshot is an exact copy of Primary snapshot at the time the copy was started. 

Introduction to Data Anchoring 
An important InstantRecovery concept to understand is Data Anchoring.  

• Data Anchoring provides a way of sharing files between snapshots. 

Using the Data Anchoring Wizard, you specify which files or folders you want to anchor (share). 
These files are available in every snapshot. In the Alpha, Beta, Gamma example used in 
Introduction to Snapshots, suppose you anchored some files. Your System Drive (for example, 
Drive C) would now look like this:  

System Drive 

 

If you booted snapshot Gamma: 
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System Drive 

 

Some points to note: 

• Data Anchoring can greatly reduce the size of each snapshot.  
• There is only one copy, the current copy, of your anchored data.  
• Anchored data files are "mapped" into the active snapshot when you boot to the snapshot.  

Since is no other copy of your anchored data on the system, it is very important that you 
maintain a backup of these data files somewhere other than your local system.  

If you attempt to anchor a file or folder that cannot be anchored, the Data Anchoring Wizard will 
notify you. 

Why Use Data Anchoring? 

Data Anchoring is a very powerful feature of InstantRecovery. However, using it depends on 
how you intend to use InstantRecovery.  

There are several modes in which you can use InstantRecovery. Two are discussed here. Other 
modes are discussed in Working with Snapshots. 

Backup Mode 

In this mode each snapshot contains a copy of all your files on the system drive. Obviously, Data 
Anchoring is not very useful in this mode since you do not want to share data between your 
snapshots. 

An exception might be a large folder of unimportant files or files that are backed up elsewhere. 
In this case anchoring the folder could save a lot of disk space and backup time. 

This mode works well if you have partitioned your disk into more than one volume (say C and 
D) and you put all the files you don't want backed up on the D drive. 

A downside to this mode is that each snapshot can take up a large amount of disk space. 
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System Recovery Mode 

In this mode the purpose of using InstantRecovery is to recover from an operating system or 
application failure. The correct use of Data Anchoring is very important in this mode. 

• You DO want to anchor important data files so that if you have to boot to an alternate 
snapshot, you don’t lose these files.  

• You DON'T want to anchor program or system files since a failure in one of these files 
would affect all your snapshots.  

Start by anchoring obvious data folders like your My Documents folder. Do not anchor your 
entire user folder (under Documents and Settings) since system files are stored under this folder.  

Also, look for large data folders that you don't need (or want) to duplicate like a folder of MPEG 
files. 

You should try and keep the number of anchored folders to a minimum. If possible, arrange your 
data files under a single anchored folder (i.e. My Documents). This will also assist you in 
backing up these files to a safe location. 

It is better to be cautious about anchoring since you will not discover you anchored the wrong 
files until you have a failure. 

Working with Snapshots 
The following is a primer on managing your snapshots. The two modes introduced in 
Introduction to Data Anchoring are expanded here. These are not the only ways InstantRecovery 
can be used but it should help you figure out the best way for you.  

Two Snapshots in Backup Mode 

If you have only two snapshots and you are using InstantRecovery in a Backup Mode then you 
should set up a schedule to update your backup snapshot on a regular basis. See Creating a New 
Schedule 

Note that this is not as safe as other modes since a virus or some other problem can be copied to 
the backup before you notice it. 

Two Snapshots in System Recovery Mode 

If you have two snapshots and you are using InstantRecovery in System Recovery Mode then 
you should manually update your backup snapshot as necessary. 

Before you install a new application, add new hardware, run Windows Update or any other 
change to your system, refresh your backup snapshot. This way if the change turns out to be 
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disastrous, you can simply boot the backup snapshot and copy it back over your primary 
snapshot undoing the change. 

After a few days when you are satisfied that the change has no problems, update your backup 
snapshot. 

Alternating Daily Backups 

With three snapshots, primary plus two backup snapshots (either in Backup or System Recovery 
mode), you can set up a schedule to update your backup snapshots on alternate days. 

Create two daily schedules each occurring every two days. Start one schedule a day later than the 
other. 

In the event of a failure, try booting the most recent backup snapshot first. If that does not work, 
use the other backup. 

This method can easily be extended to a rotating series of backups by having more than two 
backup snapshots. 

Weekly and Daily Backups 

With three snapshots, primary plus two backup snapshots (either in Backup or System Recovery 
mode), you can set up a schedule to have a daily backup and a weekly backup. 

Create two weekly schedules. Set one to occur on just one day of the week (weekly). Set the 
other to occur on the rest of the days (daily). 

In the event of a failure, try booting the daily backup snapshot first. If that does not work, use the 
weekly backup. 

Per User Snapshots 

InstantRecovery is more than a backup or recovery application. You can use it to manage and 
protect your computer. 

If you have multiple users of your computer, you can set up a snapshot for each of them. They 
can then customize their snapshots without affecting the others. Any applications they install or 
download are only in their snapshot. 

Set the Boot Hotkey (under Tools>Options) to None. That way, you are always presented with a 
choice of snapshots when the computer is booted. 

You may also want to create an additional safe snapshot that is not used so that you can copy it 
over a user’s snapshot in the event of a failure in their snapshot. 
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Special Use Snapshots 

You can also create some special purpose snapshots. Here are some suggestions: 

• OEM Snapshot - If you have a new computer, make a snapshot of the system as it came 
from the manufacturer. This way you can always go back and start over if necessary.  

• Work Snapshot - If this is a home computer you can set up a snapshot to be used to work 
from home. Any applications needed for work or configuration changes can be made in 
this snapshot and not affect your home use of the computer.  

• Game Snapshot - You can set up a snapshot just to play games. You can configure 
Windows to run your games faster by turning off a lot of the background processes 
Windows runs and not loading unwanted applications (e-mail, etc.)  

• Guest Snapshot - You can set up a snapshot for guests to use. You can protect your 
privacy since they will not have access to your files in the other snapshots. You can also 
allow then to download or install applications without worrying about their affect on your 
computer.  

Introduction to Archives 
You can save a snapshot to an Archive. An archive is a single file that contains all the files in a 
snapshot. Archives are integrated into the user interface. You can use an archive like a snapshot 
except you cannot boot an archive.  

• Archives can be updated. That is, when you copy a snapshot to an existing archive only 
the changes are copied.  

• Archives are compressed using NTFS file compression.  
• Typically, archives are faster to access than a snapshot due to the compression and the 

lack of a file system overhead.  
• Unlike snapshots, there is no predetermined limit to the number of archives you can have. 

You are only limited by the available disk space. Note, however, the performance of 
Windows drops when the system drive gets close to full.  

Tip: It is better and safer to move the archive location from the default system drive to another 
drive. The speed will be faster (if the drives are equivalent). You can even put the location on a 
network drive.  

Notes: 

If the archive location is on a network drive you will be asked to supply a user and password for 
access. 

Unlike snapshots, you cannot have a partial archive. If you cancel the archive copy operation, the 
archive will remain but is no longer valid. If you restart the operation, the entire archive will 
have to be created. 
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Archives created with Build 301 were compressed using NTFS file compression. If you store 
your archives on a non-NTFS drive, they will not be compressed.  With Build 302, archives are 
no longer compressed.  This results in improved speed in creating/updating archives. 

If you update an existing archive with a smaller snapshot, the size of the archive file does not 
decrease. Instead the unused space is marked as free and it will be reused later if possible. An 
exception is if the last file in the archive is removed, then the size is reduced. However, free 
space is zeroed so compression will reduce the actual size on disk. 

Like a file system, if an archive is updated many times, it can get fragmented. Normally, some 
fragmentation will have little effect on performance. But if you start seeing significant 
degradation while accessing an archive, the archive should be removed and recreated. 

Introduction to Schedules 
Schedules provide a method to periodically update your backup snapshots or archives to keep 
them current.  

A schedule repeats a snapshot Copy/Update at a specific frequency. For example, suppose your 
active snapshot is named "Primary Snapshot" and you have two alternate snapshots "Weekly 
Snapshot" and "Daily Snapshot". You could setup a schedule called "Weekly" to copy "Primary 
Snapshot" to "Weekly Snapshot" each Friday at 6:00 P.M. You could setup another schedule 
called "Daily" to copy "Primary Snapshot" to "Daily Snapshot" every day at 5:00 A.M. 

Schedules are actually Windows Scheduled Tasks that run the InstantRecovery command tool: 
ISRCmd.exe. You can use the Task Editor to edit the run times of the schedule. However, if you 
wish to change the Source or Destination of the schedule, remove the schedule and create a new 
one using the New Schedule feature of InstantRecovery. 

If you only maintain one copy of your primary system image, and you have all of your data files 
anchored, you should not update the secondary image unless you have installed an update, new 
application, or driver. The reason for this is that you may be copying a corrupted file that has not 
yet become apparent. 

If, on the other hand, you maintain more than one copy of your primary snapshot image, you 
may wish to schedule a daily and weekly snapshot copy. 

Introduction to Snapshot Groups 
Snapshot groups provide a means to password-protect snapshots at the pre-boot menu.  
   
Snapshot groups are only found in the Business editions of InstantRecovery.  
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Snapshot groups are user configured sets of snapshots. The groups are independent, but can 
overlap. There is the "Default" group plus up to three additional groups. Each additional group 
has a name and a password associated with it. The Default group does not have a password. 

Initially, the pre-boot menu displays all the snapshots in the Default group. The user can view 
and select the snapshots in one of the other groups by pressing the pre-boot menu hotkey and 
entering the password for that group. 

As an example, suppose you have an OEM snapshot which contains your system set up the way 
it was delivered from the manufacturer. You don't want someone to boot and use this snapshot so 
you put it in a password protected group and remove it from the Default group. 

Another use of snapshot groups is to assign only the frozen snapshot to the Default group. This 
computer could be used in a public area. The Freeze feature would restore the system back to the 
frozen state and the public user would not have access to the other snapshots. 

Note that snapshot groups only protect snapshots at the pre-boot menu. They are not meant to 
prevent a user from accessing the snapshots from the InstantRecovery Manager. You can still use 
Boot-To from the Manager to boot any snapshot. If you have users that you do not want to 
access other snapshots, make sure those users are denied administrator rights to prevent them 
from using InstantRecovery. 

Notes: 

Since you only enter a password at the pre-boot menu, the passwords of the groups must be 
unique. The group names are simply to help you organize the groups. To prevent confusion, they 
also must be unique. You cannot set the name or password for the Default group. 

To prevent a snapshot from appearing in the pre-boot menu, remove it as a member of any 
group. To keep from accidentally getting in a state where you can’t boot your computer, the 
Active snapshot must remain a member of at least one group. 

To password protect all snapshots; do not assign any snapshots to the Default group. 

Introduction to Freeze 
Freeze provides a means to revert back a snapshot to a certain state. Any changes made are 
removed the next time the frozen snapshot is booted.  
   
Freeze is only found in the Business editions of InstantRecovery.  

One way to use this feature is to: 

1. Configure your system just the way you like it. 
2. Anchor any folders that you don't want frozen (e.g. My Documents, Favorites, etc.). 
3. Freeze the system. 
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Every time the computer is booted, it is reverted back to the frozen state. Any unwanted files, 
desktop changes, viruses, or spy-ware, etc. are removed.  

Another use might be to have a "guest" snapshot. Setup a frozen snapshot for when others want 
to use your computer. Any changes made or download material is gone at the next boot. 

Freezing a snapshot will require additional storage space up to twice the size of the snapshot. 
The storage consists of an archive and a shadow snapshot. It is better and safer to move the 
freeze archive from the default system drive to another drive. The speed will be faster (if the 
drives are equivalent). You can even put the archive on a network drive. 

Only the active snapshot can be frozen. Boot the snapshot you want to freeze; make sure it is the 
way you like it and freeze it. 

Unfreeze: 

At any time, you can unfreeze your frozen snapshot and optionally remove the freeze storage. 

If you are unfreezing and intend to use Freeze again, it will save considerable time to not remove 
the freeze storage. Also, you can use Freeze Previous (see below). 

Re-freeze: 

At a later time, you can update the frozen snapshot by simply freezing it again to lock in any 
changes made since the last boot. 

If the changes are at all questionable, a safer method is to unfreeze the frozen snapshot keeping 
the freeze storage. Then test your changes. This way, if you want to discard your changes and 
start over, you simply use Freeze Previous and reboot. The snapshot will be restored to its 
previous frozen state. When you are satisfied with the changes, freeze the snapshot. 

Notes: 

Anchored Data is not frozen. Make sure any files you don't want reverted are in an anchored 
folder. 

If the freeze archive is on a network drive you will be asked to supply a user and password for 
access. 

The frozen snapshot cannot be overwritten or removed. It can, however, be copied to another 
snapshot or archive. 
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Using InstantRecovery 
Creating a Recovery Snapshot 
The current active OS is considered a snapshot. If you only have this one snapshot, the Getting 
Started Wizard will be launched whenever you start the InstantRecovery Manager:  

 

Click Next to proceed: 



InstantRecovery User Guide 

18 

 

Depending on how you intend to use InstantRecovery, you may want to specify your Anchored 
Data before creating your first snapshot. See Introduction to Data Anchoring for more 
information. Click Run Data Anchoring Wizard to set your anchored data now. 

Click Next to proceed with Getting Started: 
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Enter a name and detailed description for your new snapshot. Click Next to proceed: 

 



InstantRecovery User Guide 

20 

This is the final screen of the Wizard. Click Copy to start creating your new snapshot. This may 
take several minutes depending on the size of the snapshot and the speed of your computer. The 
progress of the copy task is displayed: 

 

After the copy task is complete, the secondary snapshot can be used to recover from a failure of 
the primary snapshot. 

You will want to refresh the secondary snapshot after you have made significant changes to the 
primary snapshot and you are confident that the changes have not introduced any problems. 

Setting Anchored Data 
To specify your anchored data, choose Tools>Data Anchoring from the menu:  

 

The Data Anchoring Wizard will be launched: 
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Click Next to proceed: 

 



InstantRecovery User Guide 

22 

Click the Add button and browse for a file or folder to add to your anchored data list. To remove 
a file or folder from the list, select it and click Remove. Click Finish to anchor the designated 
files. 

The list of anchored files is shown in the Status Bar: 

 

Controlling a InstantRecovery Task 
Some InstantRecovery actions require tasks that run in the background. These tasks are: COPY a 
snapshot, REMOVE a snapshot, and calculate the SIZE of a snapshot. When a background task 
is running, the InstantRecovery tray icon changes to the animated busy icon:  

 

Visible and Non-visible Tasks 

By default, the progress of a Scheduled Task is not visible - the only indication is the busy tray 
icon. By default, the progress of a Manual Task (a task initiated from the Menu) is visible:  

 

You can make a non-visible task visible by double-clicking or right-clicking the tray icon. 

You can make a visible task non-visible by clicking the Minimize icon in the Title Bar. 

You can change the defaults using the InstantRecovery Options. 

Canceling a Task 

You can cancel a visible task by clicking the Close icon in the Title Bar.  
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If a COPY or REMOVE task is cancelled, the target snapshot is considered "partial" and is 
indicated by a question mark (?). You can re-issue the COPY or REMOVE task later to complete 
the operation. A partial snapshot may not be bootable. 

Task Details 

If you wish to have more information or control over a task, click the Show Details button:  

 

Pause 

You can suspend a task by clicking the Pause button. The task is suspended until you click the 
button again. 

Priority 

You may find that the performance of your computer becomes unacceptable while a task is 
running in the background. This is because a task is continuously reading and writing to the disk. 
Lowering the Windows task priority (via the Task Manager) will have little effect since the 
bottle neck is the disk - not the CPU. InstantRecovery provides a better solution having less 
impact on disk I/O. This allows other applications access to the disk. 
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High - Maximum performance for InstantRecovery. 
Med - Balance between InstantRecovery and other applications. 
Low - Lowest impact on system resources.  

Transfer Info  

This provides more detailed information on the progress of the task. You can click each of the 
buttons to change the information displayed: 
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Snapshots 
Creating an Empty Snapshot 
Snapshots are usually created during the COPY operation; however, there may be a special 
situation where you will want to create an empty snapshot - creating a fresh install of an 
operating system. See Frequently Asked Questions for a technical note on how to do this.  

Create Empty Snapshot is disabled if the volume is encrypted with BitLocker. A fresh install of 
an operating system cannot be done on an encrypted volume. 

To create an empty snapshot, choose Tools>Create Empty Snapshot from the menu: 

 

The Create Empty Snapshot Wizard will be launched: 
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Click Next to proceed: 
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Enter a name and detailed description for your new snapshot. Click Finish and you will receive 
the warning: 

 

The Windows Installer will offer to format the drive. It is very important that you do not allow it 
to do so. 

Click OK to create the snapshot. 

Creating/Updating a Snapshot 
To copy a snapshot or restore an archive, choose Actions>Copy/Update Snapshot from the 
menu:  
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Alternatively you can right-click the source snapshot or archive and choose Copy/Update 
Snapshot from the pop-up menu or click the Copy icon on the toolbar: 

 

The Copy/Update Wizard will be launched: 

 

Click Next to proceed: 
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Select the snapshot or archive that will be the source of the copy operation. The active snapshot 
is the one with the blue arrow. Archives have the camera icon. Click Next to proceed: 
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Select the snapshot or archive that will be the destination of the copy operation. To create a new 
snapshot, select <New Snapshot> or <New Compressed Snapshot>. To create a new archive, 
select <New Archive>. Click Next to proceed: 

 

If you chose to create a new snapshot or archive, enter a unique name and detailed description 
for the new snapshot or archive. Click Next to proceed: 
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This is the final screen of the Wizard. Click Copy to start the operation. This may take several 
minutes depending on the size of the snapshot and the speed of your computer. The progress of 
the copy task is displayed: 

 

After the copy task is complete, the destination snapshot or archive will be a point-in-time copy 
of the source snapshot. 

Renaming a Snapshot or Changing its Description 
To rename a snapshot or archive choose Actions>Rename Snapshot from the menu:  
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Alternatively you can right-click a snapshot or archive and choose Rename Snapshot from the 
pop-up menu. 

The Rename Snapshot Wizard will be launched: 

If a snapshot or archive has already been selected, the wizard will begin with the 
Name and Description screen (unless this is the first time using this wizard or the 
"Show this introduction each time" checkbox is checked).  
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Click Next to proceed: 

 



InstantRecovery User Guide 

34 

Select the snapshot or archive to rename. Click Next to proceed: 

 

Change the name and/or description of the selected snapshot or archive. In the above example 
"Gold Snapshot" has been renamed to "Gold Snapshot - Good". Click Finish to make the 
changes. 

Importing a Snapshot 
To import a snapshot you previously exported, choose Tools>Import Snapshot from the menu:  

 

The Import Snapshot Wizard will be launched: 
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Click Next to proceed: 
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Enter the full path name of the file to import or click Browse for an Open dialog. 

Click Next to proceed: 

 

Select the snapshot that will be the destination of the import operation. To create a new snapshot 
select <New Snapshot>. 

Click Next to proceed: 
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If you chose to create a new snapshot, enter a unique name and detailed description for the new 
snapshot. 

Click Next to proceed: 
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Click Import to start importing the snapshot. This may take several minutes depending on the 
size of the snapshot and the speed of your computer. The progress of the import task is 
displayed: 

 

  

Exporting a Snapshot 
To export a snapshot to a file for off-site backup purposes, choose Tools>Export Snapshot from 
the menu:  
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The Export Snapshot Wizard will be launched: 

 

Click Next to proceed: 
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Select the snapshot to export. Click Next to proceed: 
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Enter the full path name of the file or click Browse for a Save dialog. 

If you are intending to copy the file to fixed-sized media (such as CD or DVD), check the split 
file box and enter the maximum capacity of the media in Mb. The first part will have the 
extension .ARX, the second will have .001 and so on. 

If disk space on the destination drive is an issue or you want to change the media, you can check 
the prompt box and you will be prompted before the copy engine starts another part of the file. 

Click Next to proceed: 

 

Click Export to start exporting the selected snapshot. This may take several minutes depending 
on the size of the snapshot and the speed of your computer. The progress of the export task is 
displayed: 
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Password-Protecting Snapshots 
To password-protect one or more snapshots in the pre-boot menu, you must put them in a 
snapshot group other than the Default group. Choose Tools>Snapshot Groups from the menu:  

 

The Snapshot Groups Wizard will be launched: 
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Click Next to proceed: 
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Initially all of your snapshots are in the Default group. This group is not password-protected. To 
create a password-protected group, click Add Group and you will be prompted to enter the new 
group's name: 

 

Group names can be up to 15 characters long and must be unique. Click OK and you will be 
prompted to enter a password for the new group: 

 

Passwords can be up to 15 characters long and must be unique. Click OK and the group will be 
added. 

Initially, there are no snapshots in the new group. Select the snapshots you want to have in this 
password-protected group by clicking the check boxes in front of them: 
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You can add another group with a different password: 
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Now remove those snapshots you want password-protected from the Default group by clicking 
the check boxes in front of them: 

 

Note that, in the above example, Primary Snapshot is in both the Default and Test groups. 
You may find it convenient to have snapshots in more than one group so they are shown 
together in the pre-boot menu.  

Click Finish to save your changes.  
   
Snapshots groups are only found in the Business editions of InstantRecovery.  

Snapshot groups only protect snapshots at the pre-boot menu. They are not meant to prevent a 
user of InstantRecovery from accessing the snapshots. You can still use Boot-To from the 
Manager to boot any snapshot. If you have users that you do not want to access other snapshots, 
make sure those users are non-admin and prevent them from using InstantRecovery. 

Removing a Snapshot 
To remove a snapshot or archive, choose Actions>Remove Snapshot from the menu:  
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Alternatively you can right-click a snapshot or archive and choose Remove Snapshot from the 
pop-up menu or click the Remove icon on the toolbar: 

 

The Remove Snapshot Wizard will be launched: 

If a snapshot or archive has already been selected, the wizard is skipped and you 
are only prompted to confirm the removal (unless this is the first time using this 
wizard or the "Show this introduction each time" checkbox is checked).  



InstantRecovery User Guide 

48 

 

Click Next to proceed: 
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Select the snapshot or archive you wish to remove. 

Note: The active snapshot is not listed because it cannot be removed. 

Click Remove and you will be asked to confirm the operation: 

 

Click Yes to start removing the selected snapshot or archive. This may take several minutes 
depending on the size of the snapshot and the speed of your computer. The progress of the 
remove task is displayed: 

 

You should remove or modify any schedules that use this snapshot or archive as a source. 

  

Calculating the Size of a Snapshot 
Typically you will not have to calculate the size of a snapshot since the size of the destination 
snapshot is set after the copy operation. However, the size of the active snapshot can vary and 
you may wish to know its current size.  

To calculate the size of a snapshot, choose Actions>Calculate Snapshot Size from the menu: 
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Alternatively you can right-click a snapshot and choose Calculate Snapshot Size from the pop-up 
menu or click the Calculate Size icon on the toolbar: 

 

The Calculate Snapshot Size Wizard will be launched: 

If a snapshot has already been selected, the wizard is skipped and 
InstantRecovery begins calculating the size of the snapshot immediately (unless 
this is the first time using this wizard or the "Show this introduction each time" 
checkbox is checked).  
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Click Next to proceed: 
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Select the snapshot whose size is to be calculated. 

Click Calculate to initiate the operation. This may take several minutes depending on the size of 
the snapshot and the speed of your computer. The progress of the copy task is displayed: 

 

The progress bar is not updated during a SIZE operation since the number of directories to be 
indexed is not known before the operation. 

Freezing a Snapshot 
Freeze is only found in the Business editions of InstantRecovery. 

To freeze your active snapshot, choose Actions>Freeze from the menu:  

 

The Freeze Snapshot Wizard will be launched: 
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Freezing a snapshot will require additional storage space up to twice the size of the snapshot. 
The storage consists of an archive and a shadow snapshot. It is better and safer to move the 
freeze archive from the default system drive to another drive. You should set the freeze archive 
location before freezing. See Freeze Options to learn how to set the freeze archive location. 

Click Freeze and you will be asked to confirm the operation: 

 

Since the current state of your system will be frozen, you will want to make sure it is as clean as 
possible. Before freezing the active snapshot, you should have rebooted your computer; run Disk 
Cleanup on the system drive; and then logged out and back in to save your user settings. 
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Click Yes to start the freeze operation. This may take several minutes depending on the size of 
the snapshot and the speed of your computer. The progress of the freeze task is displayed: 

 

After the operation is complete, the frozen snapshot will be designated with a blue star over the 
snapshot icon: 

 

Every time you boot the frozen snapshot it will be restored to the frozen state. InstantRecovery 
begins repairing the changes made during the previous session immediately at startup. If it has 
not completed the repair by the time you log in, you will be asked to wait:  

You can turn off the wait prompt from Advanced Options and the repair process will not be 
affected. However, rebooting the computer before the process completes may result in your 
system being in an undetermined state. Rebooting again and waiting for the repair to complete 
will fix this. 

Unfreezing a Snapshot 
Freeze is only found in the Business editions of InstantRecovery. 

To unfreeze your frozen snapshot, choose Actions>Unfreeze from the menu:  
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The Unfreeze Snapshot Wizard will be launched: 

 

Click Next to proceed: 
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Choose to keep or remove the freeze storage. Select this option if you intend to refreeze the 
snapshot later. It will allow you to use Freeze Previous to revert the snapshot to its previous 
frozen state if you decide you want to undo the changes. Also, select this option if you intend to 
freeze another snapshot later. It will likely be much quicker even if the snapshots are different. 

Click Unfreeze to proceed. You will be prompted for confirmation: 

 

Click Yes to initiate the unfreeze operation. If you chose to remove the storage the progress of 
the task is displayed: 
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Reverting a Snapshot to Its Previous Frozen State 
To revert a snapshot to its previously frozen state, choose Actions>Freeze Previous from the 
menu:  

 

You will be prompted for confirmation: 
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Click Yes to revert the snapshot to its previously frozen state. 

The snapshot will be marked as frozen but will not revert until the next boot. 

You must have kept the freeze storage intact to revert. Starting another freeze operation or 
moving the freeze archive to another drive will prevent you from reverting. 

Freeze Previous will revert the previously frozen snapshot no matter what the current active 
snapshot is. 

Booting to Another Snapshot 
There are two methods you can use to boot to another snapshot:  

1. Use Boot to Snapshot. 
2. Press the hotkey (default F1) during the pre-boot. 

Boot to Snapshot 

If you are within the operating system interface, to boot a snapshot, choose Actions>Boot to 
Snapshot from the menu:  

 

Alternatively you can right-click a snapshot and choose Boot to Snapshot from the pop-up menu. 

The Boot to Snapshot Wizard will be launched: 

If a snapshot has already been selected, the wizard is skipped and you are only 
prompted to confirm the boot to snapshot (unless this is the first time using this 
wizard or the "Show this introduction each time" checkbox is checked).  
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Click Next to proceed: 
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Select the snapshot you wish to boot. Click Boot Now and you will be asked to confirm the 
operation: 

 

If you answer Yes, Windows will attempt to reboot your computer. After the reboot your active 
snapshot will be the one you selected (e.g. Secondary Snapshot). 

If Windows cannot shutdown (e.g. an application refuses to close) the boot to the selected 
snapshot will occur the next time you boot your computer unless you run the InstantRecovery 
Manager. If the InstantRecovery Manager is run again, the boot to snapshot is cancelled. 

When you login after swapping to another snapshot, the InstantRecovery tray icon notifies you 
that you have booted to another snapshot: 

 

You can also hold the mouse over the tray icon and the tip message will tell you the active 
snapshot: 

 

Pre-boot Hotkey without BitLocker 

When InstantRecovery is installed and enabled you will see the following when your computer 
boots:  
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If you do not press the Hotkey (default is F1) or if you press any other key than the Hotkey, your 
computer boots normally. 

If you press the Hotkey before the red progress bar reaches the end, the InstantRecovery pre-boot 
menu loads: 

 

Using the arrow keys select the snapshot you wish to boot and press Enter. You will be prompted 
for confirmation before any changes are made to the disk. If you do not want to boot the selected 
snapshot, reboot your computer with Ctrl-Alt-Del. 



InstantRecovery User Guide 

62 

The active snapshot is designated with an asterisk (*). Selecting this snapshot is the same as if 
you had not pressed the Hotkey - the computer boots the same snapshot. 

The frozen snapshot (if any) is designated with a number sign (#). 

Partial snapshots, those where the copy/update function was halted, are designated with a 
question mark (?). These snapshots may not be bootable. 

Pre-boot Hotkey with BitLocker 

If BitLocker is installed the pre-boot hotkey is available after BitLocker is loaded but before 
Windows starts. You will see the Windows logo and then the hotkey prompt:  

 

If you do not press the Hotkey (default is F1) or if you press any other key than the Hotkey, your 
computer boots normally. 

If you press the Hotkey before the countdown reaches 0, the InstantRecovery pre-boot menu 
loads: 
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Using the arrow keys select the snapshot you wish to boot and press Enter. You will be prompted 
for confirmation before any changes are made to the disk. 

Snapshot Groups 

Note: Snapshot Groups are only available in InstantRecovery Server. 

When the pre-boot menu first loads, only the snapshots in the Default group are displayed. To 
view the snapshots in other groups, press the hotkey again. You will be prompted to enter the 
password for that group. To return to the Default group, press the hotkey and then press ENTER 
for the password. 
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Schedules 
Creating a New Schedule 
Choose Schedule>Create New Schedule from the menu:  

 

Alternatively you can right-click in the schedules area and choose Create New Schedule from the 
pop-up menu or click the New Schedule icon on the toolbar: 

 

The Create New Schedule Wizard will be launched: 

 

Click Next to proceed: 
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Enter a unique and descriptive name for the new schedule. Click Next to proceed: 
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Select the snapshot that will be the source of the copy operation. The active snapshot is the one 
with the blue arrow. Click Next to proceed: 

 

Select the snapshot or archive that will be the destination of the copy operation. To create a new 
snapshot, select <New Snapshot>. To create a new archive, select <New Archive>. Click Next to 
proceed: 
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Set the start time and the frequency for the new schedule. You have the choice of Daily (above), 
Weekly: 
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or Monthly: 

 

Addition frequency settings are available with the Schedule Editor. Click Next to Proceed: 
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Enter the username and password that the schedule will run under. The user must have full 
administrative privileges. The password is required. The schedule will not run if the user does 
not have a password. Click Next to proceed: 
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Click Finish to create the schedule. 

See Also: 

Introduction to Schedules 
Schedule Options 
Controlling a InstantRecovery Task 

Modifying a Schedule 
Choose Schedule>Edit Schedule from the menu:  

 

Alternatively you can right-click a schedule and choose Edit Schedule from the pop-up menu. 

The Edit Schedule dialog will be launched: 

If a schedule has already been selected, the dialog is skipped.  
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Click Edit to launch the Windows Scheduled Task Editor: 
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The only user modifiable part of a InstantRecovery schedule is the frequency settings on the 
Schedule tab above. If you need to change the source or destination snapshot, you should remove 
the schedule and create a new one with the changes. 

Click OK to save the changes. 

Renaming a Schedule 
Choose Schedule>Rename Schedule from the menu:  

 

Alternatively you can right-click a schedule and choose Rename Schedule from the pop-up menu. 

The Rename Schedule Wizard will be launched: 
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If a schedule has already been selected, the selection screen below is skipped.  

 

Select a schedule from the list and click Next to proceed: 
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Enter a new name for the schedule and click Finish to make the change. 

Removing a Schedule 
Choose Schedule>Remove Schedule from the menu:  

 

Alternatively you can right-click a schedule and choose Remove Schedule from the pop-up menu. 

The Remove Schedule dialog will be launched: 

If a schedule has already been selected, the dialog is skipped.  
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Select the schedule to remove and click Remove. You will be prompted for confirmation: 

 

Click Yes to remove the schedule. 
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Logs 
Viewing the Activity Log 
To view the InstantRecovery Activity Log, choose Tools>View Activity Log from the menu:  

 

Alternatively you can click the Activity Log icon on the toolbar: 

 

The InstantRecovery Activity Log Viewer will be launched: 
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This program allows you to view, filter and export the InstantRecovery Activity Log. Log entries 
marked with a blue plus (+) indicate that there are details associated with this entry. Click one of 
these entries to view the details: 
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The log entries can be filtered by event, date or type. Choose View>Filter from the menu or click 
on the Filter toolbar icon: 

 

Events are: 



InstantRecovery User Guide 

80 

 

Types are: 

 

The filtered main log or the detail log can be exported to a text file for printing or archive. 
Choose the File menu or click on the Export toolbar icon: 

 

Select Main or Detail Log to export. You will be prompted to select the name and location of the 
exported log. 

Clearing the Log Entries 
Normally there is no reason to clear the InstantRecovery Activity Log - log entries are 
automatically purged after they reach a specified age.  

To clear the Activity Log, choose Tools>Clear Log Entries from the menu: 
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You will be prompted to confirm the action: 

 

If you answer Yes, the log will contain only an entry noting the clear event. 
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Options 
General Options 
The Options area offers several user choices to customize InstantRecovery to your specific 
needs. Options are found in the user interface pull-down menu, Tools>Options. Click the top 
tabs to select the various option groups.  

The "General" tab contains the following program customizations. After changing an option, 
click "OK" to accept changes or "Cancel" to leave options unchanged and return to the main user 
interface. 

 

System Tray Icon 

InstantRecovery can provide a visible indication of its status via a small icon located in the 
Windows system tray. Unless the tray icon is set to No Tray Icon, if a serious error has occurred, 
the tray icon will appear with a red colored 'X'. 

Double-clicking on the system tray icon will bring up the main interface. If a task is currently in 
operation, the status of the task will be displayed and made the topmost window. 

Right clicking on the system tray icon will display a popup menu to allow the selection of 
opening the main interface or any processing task (copy, remove, size calculation). 
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No Tray Icon 

Do not use the system tray icon.  
Note that if this option is selected, the Manager will not automatically refresh when data 
changes. You must press F5 to refresh the display.  

Always Show  
Always show the system tray icon and reflect the current status of InstantRecovery. If any 
task is currently being processed (copy, remove, size calculation) a small animated clock 
will appear over the icon.  

Show During Activity  
Show During Activity will only show the system tray icon during a processing task (copy, 
remove, size calculation). A small-animated clock will appear over the icon. After all tasks 
have completed the icon will be removed from the system tray, but InstantRecovery 
continues to protect your system.  

Introduction Splash Screens  

Many of the program's wizards have an opening screen that displays important information 
concerning the requested action. You can manually set the default condition to not display these 
introduction screens. A checked condition defaults the screen to be displayed. 

Boot Menu Options 
The "Boot Menu" tab contains customizations to the pre-Windows boot menu. After changing an 
option, click "OK" to accept the changes or "Cancel" to leave options unchanged and return to 
the main user interface.  
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Boot Preferences 

Display hotkey and pause bar: 

The pre-Windows boot splash screen logo is always displayed when the product is installed 
and enabled. The hotkey and pause bar, which is waiting for a user to press the hot key 
during its timeout, can be hidden from view. The system will continue to pause for the 
hotkey entry during this time.  

Pre-boot menu timeout:  
By default, after the boot hotkey is pressed, if no key is pressed for 30 seconds, the boot 
menu will timeout and the computer will boot normally. You can disable this behavior or 
change the timeout period from as short as 10 seconds to as long as two minutes.  

Boot Hotkey  

During the boot process when the product splash screen is displayed, a pause occurs while 
waiting for the user to press the boot hotkey. The hotkey is used to display the alternate OS 
snapshots that can be booted. Your choice of hotkey may be selected from any of the keyboard 
functions shown. F8 has been removed since it is the default key to access the internal Windows 
boot menu. To always display and wait at the boot screen, select the 'None' option. 

Boot Splash Delay 

This is the delay when waiting for the boot hotkey to be pressed. 
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Task Options 
The "Tasks" tab contains customizations to the manually run process during Copy, Remove, or 
Size calculation actions. After changing an option, click "OK" to accept the changes or "Cancel" 
to leave the options unchanged and return to the main user interface.  

 

Task Preferences 

Visibly display progress of tasks: 

By default, a manually started action brings up a window showing the status and progress of 
the action. Un-checking this option will start the action with the window hidden.  

Play sound after task completion:  
When a task completes, a sound (chirp) is played. Un-checking this option will cause the 
sound not to play.  

Verify destination snapshot after copy:  
After the copy completes, verification can occur as a confirmation that the destination files 
were copied.  

Default Task Priority  

A manually started action will process in the background with an assigned priority. The priority 
used will determine the impact of the action on the system processor and disk activity. A higher 
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priority will complete the action sooner, but uses more system resources. If you would like the 
action to take a longer background role and use less system resources, select a lower priority. 

Excluded Files 

Enter the list of files you want excluded from copy operations. Wildcards '*' and '?' are 
permitted. Put each item in the list on a separate line. To add more than one item, press Shift-
ENTER to go to the next line. 

You can also browse for a specific file or folder to add to the list. 

To delete an item, highlight the text of the item and press DELETE. 

Exclude System Restore data: 

If checked, this option will exclude System Restore data when copying a snapshot or 
creating an archive. If System Restore is turned on, the destination snapshot or archive will 
have System Restore turned on but no restore points. If System Restore is turned off 
(recommended) the option has no affect.  
   
   

   

Schedule Options 
The "Schedules" tab contains customizations to the scheduled processes during a Copy, Remove, 
or Size calculation. After changing an option, click "OK" to accept the changes or "Cancel" to 
leave options unchanged and return to the main user interface.  
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Scheduled Task Preferences 

Visibly display progress of scheduled tasks: 

By default a scheduled action runs silent in the background. Checking this option will cause 
the window to be shown.  

Play sound after schedule completion:  
When a task completes, a sound (chirp) is played. Un-checking this option will cause the 
sound not to play.  

Verify destination snapshot after copy:  
After the copy completes, verification can occur as a confirmation that the destination files 
were copied.  

Default Task Priority  

A scheduled action can process in the background with an assigned priority. The priority used 
will determine the impact the action has on the system processor and disk activity. A higher 
priority will complete the action sooner, but uses more system resources. 

Logging Options 
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The "Logging" tab contains customizations to the activity log. After changing an option, click 
"OK" to accept the changes or "Cancel" to leave options unchanged and return to the main user 
interface.  

 

Logging Preferences 

Purge Log entries older than "x" days 

If you wish to automatically purge all log entries older than a given number of days, check 
this option. You also need to enter the number of days to keep log entries. Any log entries 
older than the number of days entered will be purged automatically.  

View Logs  
Click to view the non-purged logs.  

Clear Logs  
Click to clear ALL log entries. You will not be able to restore these once they are removed.  

   

Archive Options 
The "Archives" tab contains customizations to Archives. After changing an option, click "OK" to 
accept the changes or "Cancel" to leave options unchanged and return to the main user interface.  
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Archive Location 

Specify an alternate archive location: 

It is better and safer to move the archive location from the default system drive to another 
drive. The speed will be faster (if the drives are equivalent) since the computer can be 
reading from one drive while writing to another.  

Check the box and enter the full path to the archive location or click Change to browse for a 
folder. 

User for network access:  
If the alternate archive location is on a network drive you will be asked to supply a user and 
password for access:  
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The Archive Location will look similar to this: 

 

You can change the user and password later by clicking the Change button next to the user 
name. 

Freeze Options 
Freeze is only found in the Business editions of InstantRecovery. 

The "Freeze" tab contains customizations to Freeze. After changing an option, click "OK" to 
accept the changes or "Cancel" to leave options unchanged and return to the main user interface.  
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Freeze Preferences 

Delay login while updating freeze storage: 

InstantRecovery begins repairing the changes made to the frozen snapshot immediately at 
startup. Check this option if you want to delay the user login until the repair is complete.  

Message:  
Enter the message you want displayed to the user on the delay prompt.  

Freeze Storage  

Disk space used: 

This is the amount of additional disk space used for freeze storage. If there is no frozen 
snapshot you can click on Clean Storage to recover this space.  

Use alternate freeze archive name:  
It is better and safer to move the freeze archive from the default system drive to another 
drive. The speed will be faster (if the drives are equivalent) since the computer can be 
reading from one drive while writing to another.  

Check the box and enter the full path name of the alternate freeze archive or click Change to 
browse for a file. 
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User for network access:  
If the alternate freeze archive is on a network drive you will be asked to supply a user and 
password for access:  

 

The Freeze Storage will look similar to this: 

 

You can change the user and password later by clicking the Change button next to the user 
name. 





 

95 

Advanced 
Command Line Interface 
InstantRecovery includes a command line control program: ISRControl.exe which can be used in 
batch files or as part of a script.  

All of the operations available in the Graphical interface are also available in the Command Line 
interface. 

Opening the Command Line Interface in Interactive Mode 

To open the InstantRecovery Command Line Interface in Interactive Mode, select the Start 
Button, and then navigate to Programs, InstantRecovery, and finally InstantRecovery Control.  

You should see a command line box appear, with the version number and the '>' prompt. 

From this point on, a command is issued by typing-in the command at the '>' prompt. There is no 
mouse support within the command line interface. 

At any time you can get a quick reference about available commands by typing HELP at the 
command line prompt. Also, for most commands, you can just type the commands without 
parameters and you will get help on that command. 

You can exit the command line interface at any time with the EXIT command. 

Running the Command Line Interface in Single Command Mode 

You can run ISRControl.exe from a batch file or a Command Prompt and pass a single command 
to execute on the command line. ISRControl.exe exits after processing that command.  

Getting Logging Info for Snapshots and the InstantRecovery Service 

From time to time you will require detailed information about each snapshot and the status of the 
InstantRecovery Service. The command line interface contains several methods to retrieve 
information about the snapshots, and the service. It collects information about the snapshot status 
(active or not), the creation dates, the last modification dates, last boot dates, the approximate 
snapshot sizes, and a brief user description.  

The InstantRecovery log is a detailed log of all events and errors. You can find this log at: 

<system drive>\$ISR\$LOGS\ISR.log  
Detail logs containing and folders/files processed are at:  
<system drive>\$ISR\$LOGS\xxxxxxxx.log  
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Where xxxxxxxx is an incrementing number. A new detail log file is created for each command 
involving the copy engine.  

ANCHOR Command 

Data anchoring allows the user to select any combination of folders and files to be left intact 
during a failover operation. Example: the "My Documents" directory can be anchored. During an 
Immediate System Recovery boot, the anchored folder and files will remain intact after the 
recovery.  

The ANCHOR command is used as follows: 

ANCHOR <folder or file>; <folder or file>; ...  
Each folder or file must be delimited by a semi-colon (;). Wildcards are not allowed. The folder 
and/or file list must not exceed 700 characters and 32 entries.  

Examples: 

To anchor a specific user My Documents folder: 

ANCHOR C:\Documents and Settings\<username>\My Documents  
To anchor a specific file, such as C:\temp\myfile.txt:  
ANCHOR C:\temp\myfile.txt  
To anchor several folders, such as C:\Games and C:\temp:  
ANCHOR C:\Games; C:\Temp  
To view the current anchored folders and/or files:  
ANCHOR  
If you anchor a folder or file that pre-exists in another snapshot, the anchored folders or files will 
take precedence. When the anchoring is removed the pre-existing snapshots will return to 
normal.  

ARCHIVE Command 

The ARCHIVE command provides a method to create or update an archive.  

The ARCHIVE command is used as follows: 

ARCHIVE <snapshot name> <archive name> ["<description>"] [EXCLUDE 
<folder/file>;<folder/file>;...]  

The <snapshot name> is the name of the snapshot to be copied. Wildcards (*,?) can be used to 
select an existing snapshot. Use double quotations when the snapshot name contains spaces.  

The <archive name> is the name of the archive to create or update. If the <archive name> does 
not exist, a new archive will be created. Wildcards (*,?) can be used to select an existing archive. 
Use double quotations when the archive name contains spaces. 
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The <description> is the archive description. The description must not exceed 127 characters. 

If folders or files exist that you do not wish to copy, use the EXCLUDE parameter. Each 
excluded folder and/or file must be delimited by a semi-colon (;). Wildcards (*,?) can be used to 
provide a grouping of folders or files. 

All the folders and files in the anchored file list are automatically excluded from the copy. 

Examples: 

To create or update the archive "Archive of Primary": 

ARCHIVE Primary "Archive of Primary" "A backup of Primary" EXCLUDE 
*.tmp;C:\Games  

To create or update the archive "Temp Archive" with no description or excluded files:  
ARCHIVE Primary "Temp Archive"  

AREMOVE Command 

The AREMOVE command will remove one or more archives.  

The AREMOVE command is used as follows: 

AREMOVE <archive name>  
The <archive name> is the name of the archive(s) to remove. Wildcards (*,?) can be used to 
select one or more archives. Use double quotations when the archive name contains spaces.  

Examples: 

To remove an archive named "Temp Archive": 

REMOVE "Temp Archive"  
To remove all archives whose names begin with "Temp":  
REMOVE Temp*  

ARENAME Command 

The ARENAME command is used to rename and/or change the description of an archive.  

The ARENAME command is used as follows: 

ARENAME <archive name> <new name> ["<description>"]  
The <archive name> is the current name of an archive. Wildcards (*, ?) can be used to select the 
archive. Use double quotations when the archive name contains spaces.  
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The <new name> is the new name of the archive. Use "" if you want to just change the 
description. 

The <description> is the archive description. The description must not exceed 127 characters. 

Examples: 

To rename archive "Temp Archive" to "Archive (2) of Primary" and set the description to 
"Another backup of Primary": 

ARENAME "Temp Archive" "Archive (2) of Primary" "Another backup of 
Primary"  

To just change the name of archive "Archive (2) of Primary" to "2. Archive of Primary":  
ARENAME "Archive (2) of Primary" "2. Archive of Primary"  
To just change the description of "2. Archive of Primary":  
ARENAME 2* "" "Second backup of Primary"  

BATCH Command 

The BATCH command allows you to execute a list of commands saved in a file. While the 
BATCH command can be used in interactive mode, it is probably most useful in single command 
mode. Each command in the file is executed in sequence. Execution stops at end of file or at the 
first error encountered.  

The BATCH command is used as follows: 

BATCH <file name>  
The <file name> is the name of the file containing the command list.  

Examples: 

To execute the list of commands in the file named "Batch1": 

BATCH Batch1  
To execute the list of commands in the file named "My Commands.lst":  
BATCH My Commands.lst  

BOOT Command 

The BOOT command boots to another snapshot.  

The BOOT command is used as follows: 

BOOT [<snapshot name>]  
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The <snapshot name> is the name of the snapshot to be booted. Wildcards (*,?) can be used to 
select an existing snapshot. Use double quotations when the snapshot name contains spaces.  

If no snapshot specified the computer is rebooted. 

Examples: 

To boot the snapshot that begins with "Secondary": 

BOOT Secondary*  
To reboot the computer:  
BOOT  

CONFIG command 

Most InstantRecovery configuration settings are available from the command line. The general 
form is  
CONFIG <parameter> [<setting>]  
If the <setting> is omitted the current value of the parameter is displayed.  

The configuration parameters available are: 

CONFIG preboot [enable | disable]  
Enable or disable the InstantRecovery pre-boot.  
CONFIG hotkey [F1 | . . . | F10], F0 = None  
Set the pre-boot Hotkey  
CONFIG keywait [delay in seconds]  
Set the wait time for the Hotkey in fractions of a second.  
CONFIG showprompt [yes or no]  
Set if the pre-boot prompt is displayed.  
CONFIG menutimeout [timeout in seconds]  
Set the timeout for the pre-boot menu in seconds.  
CONFIG lastboot  
Get the last boot date and time (read only).  
CONFIG lastswap  
Get the last swap over date and time (read only)  
CONFIG keeplogs [days]  
Set the number of days to keep the logs: < 0 = forever. 0 = purge logs.  
CONFIG license [key]  
Set the license key.  
CONFIG active [snapshot id]  
Set the Boot to Snapshot id. InstantRecovery will boot to this snapshot at the next 
boot: 0 = no boot to snapshot.  

InstantRecovery preferences stored in the Registry can be set with the CONFIG command:  
CONFIG TrayIconAppearance [never | always | busy]  
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CONFIG DefaultExclusionList [exclude filelist] 

CONFIG TaskVisible [false or true] 

CONFIG BeepAfterTask [false or true] 

CONFIG VerifyAfterCopy [false or true] 

CONFIG DefaultPriority [high | medium | low] 

CONFIG SchdTaskVisible [false or true] 

CONFIG SchdTaskBeep [false or true] 

CONFIG SchdTaskVerify [false or true] 

CONFIG SchdTaskPriority [high | medium | low] 

InstantRecovery options stored in the $OPT file can be set with the CONFIG command:  
CONFIG ArchiveLocation [new archive location]  

CONFIG ArchiveUser [new archive domain\\user] 

CONFIG ArchivePassword password 

CONFIG FreezeShowWait [false or true] 

CONFIG FreezeWaitPrompt [prompt] 

CONFIG FreezeTaskPriority [high | medium | low] 

CONFIG FreezeArchiveName [new archive name] 

CONFIG FreezeArchiveUser [new freeze archive domain\user] 

CONFIG FreezeArchivePassword password 

CONFIG ManagerPassword password 

CONFIG RemotePortNumber [port] 

CONNECT Command 

The CONNECT command allows you to configure and control InstantRecovery on another 
computer.  
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The CONNECT command is used as follows: 

CONNECT <computer>[:<port>] [<user>] [<password>]  
The <computer> is the name or IP address of the remote computer you want to control.  

The <port> is necessary if you want to override the default port number (48288). 

You will need to supply the name and password of a user with Administrator or Domain 
Administrator rights on the remote computer. If you don't enter them on the command line you 
will be prompted for them. If you are supplying a domain user, enter the user in the form 
domain\user. 

Examples: 

To connect to the computer TEST and be prompted for the user and password: 

CONNECT TEST  
To connect to the computer TEST and be prompted for password for tester:  
CONNECT TEST tester  
To connect to the computer TEST on port 12345:  
CONNECT TEST:12345  
   
CONNECT is not available in InstantRecovery Home.  
   
See Remote Controlling InstantRecovery.  

COPY Command 

The COPY command provides a method to create or update a snapshot. You can create and 
maintain up to ten snapshots, all maintaining a bootable point in time snapshot of your system. 
The COPY command always works as an incremental copy. This means that if the file is a 
duplicate in the snapshot, there is no need to copy it and thus it is skipped.  

The COPY command is used as follows: 

COPY <source name> <destination name> [EXCLUDE 
<folder/file>;<folder/file>;...]  

The <source name> is the name of the snapshot to be copied. Wildcards (*,?) can be used to 
select an existing snapshot. Use double quotations when the snapshot name contains spaces.  

The <destination name> is the name of the snapshot to create or update. If <destination name> 
does not exist, a new snapshot will be created. Wildcards (*,?) can be used to select an existing 
snapshot. Use double quotations when the snapshot name contains spaces. 
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If folders or files exist that you do not wish to copy, use the EXCLUDE parameter. Each 
excluded folder and/or file must be delimited by a semi-colon (;). Wildcards (*,?) can be used to 
provide a grouping of folders or files. 

All the folders and files in the anchored file list are automatically excluded from the copy. 

Examples: 

To create or update snapshot "Secondary" excluding C:\Games and C:\MP3 Music: 

COPY Primary Secondary EXCLUDE C:\Games;C:\MP3 Music  
To copy snapshot "Secondary" to snapshot "OEM Build" with no excluded files:  
COPY Secondary "OEM Build"  
Note: Using the COPY/EXCLUDE and ANCHOR commands can be very powerful. Example: 
You have 60 GB of MP3 files that are backed up by another source. You have no need to copy 
them to each Snapshot. Using the COPY and EXCLUDE function will exclude them during the 
snapshot copy process. Using the ANCHOR function will keep them intact after a failover.  

DESC Command 

The DESC command will modify the description that is linked to a specific snapshot. The 
description is seen at the InstantRecovery pre-Windows boot screen and during an INFO 
command.  

The DESC command is used as follows: 

DESC <snapshot name> "<description>"  
The <snapshot name> is the name of the snapshot whose description you want to set. Wildcards 
(*,?) can be used to select an existing snapshot. Use double quotations when the snapshot name 
contains spaces.  

The <description> is the snapshot description. The description must not exceed 127 characters. 

Examples: 

To change the description of snapshot "Primary": 

DESC Primary "This is my default active snapshot."  
To change the description of snapshot "OEM Build":  
DESC "OEM Build" "This is my default OEM Build with latest drivers installed."  

DISCONNECT Command 

The DISCONNECT command disconnects from a remote computer. It has no effect if you are 
not connected.  
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The DISCONNECT command has no parameters. 

EXIT Command 

The EXIT command shuts down the Command Line Interface.  

The EXIT command has no parameters. 

EXPORT Command 

The EXPORT command provides a method to export a snapshot to a file or set of files.  

The EXPORT command is used as follows: 

EXPORT <snapshot name> <file name> [USER domain\user password] 
["<maximum file size>"] [PROMPT] [EXCLUDE <folder/file>;<folder/file>;...]  

The <snapshot name> is the name of the snapshot to be exported. Wildcards (*,?) can be used to 
select an existing snapshot. Use double quotations when the snapshot name contains spaces.  

The <file name> is the full path name of the export file. Use double quotations when the file 
name contains spaces. 

The <maximum file size> is the maximum size of each part of the file in Kb. If specified, the 
first part of the file will have the extension .ARX, the second part .001, and so on. 

If "PROMPT" is specified after the <maximum file size> you will be prompted before another 
part of the file is started. 

If folders or files exist that you do not wish to copy, use the EXCLUDE parameter. Each 
excluded folder and/or file must be delimited by a semi-colon (;). Wildcards (*,?) can be used to 
provide a grouping of folders or files. 

All the folders and files in the anchored file list are automatically excluded from the export. 

If the export file is on a network drive you will need to provide a user and password for access. 
Use the "USER" parameter or the USER command below. 

Examples: 

To export the snapshot "Primary" to the file E:\PrimaryBackup.arx excluding *.tmp and 
C:\Games: 

EXPORT Primary E:\PrimaryBackup.arx EXCLUDE *.tmp;C:\Games  
To export the snapshot "Primary" to the files E:\PrimaryBackup.arx, E:\PrimaryBackup.001, etc. 
With each file a maximum of 640Mb and be prompted:  
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EXPORT Primary E:\PrimaryBackup.arx 655360 prompt  
To export the snapshot "Primary" to the network location "\\TEST\DropBox":  
EXPORT Primary "\\TEST\DropBox\Primary.arx" USER TEST\Tester password  

FREEZE Command 

The FREEZE command allows you to "Freeze" the active snapshot. The frozen snapshot will be 
restored to its current state every time the system boots.  

The FREEZE command is used as follows: 

FREEZE <snapshot name>  
The frozen snapshot is designated with a #.  

Anchored Data is not frozen. 

The frozen snapshot cannot be overwritten or removed. It can, however, be copied to another 
snapshot. 

At a later time, you can update the frozen snapshot by re-freezing it to lock in any changes made 
since the last boot. 

To temporarily prevent the frozen snapshot from being restored, disable the Pre-boot before 
booting. 

Freezing a snapshot will require additional disk space equal to twice the size of the snapshot. 

It is recommended that you reboot your computer, make the changes to the snapshot, logout and 
login before freezing. This ensures "that only the changes you want get applied to the frozen 
snapshot. 

FREEZEPREV Command 

The FREEZEPREV command reverts the previously frozen snapshot to its last frozen state at the 
next boot. The Freeze Storage must still be intact for this to succeed.  

The FREEZEPREV command has no parameters. 

GROUP Command 

The GROUP command allows you to create or update snapshot groups. Snapshot groups provide 
a method to password protect snapshots during the pre-boot. There are 1 to 4 groups numbered 
0,1,2,3. Group 0 is the "Default" group and has no password. Initially, the pre-boot menu 
displays the snapshots in the default group. The user can view and select the snapshots in one of 
the other groups by entering the password for that group.  
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The GROUP command is used as follows: 

GROUP [x] [, <password>] [, <name>] [, <snapshot>, ...]  
Where x is 0, 1, 2 or 3.  

Groups 1, 2 and 3 must be given a name but the name is only used by the Manager. The names 
and passwords must be unique. You cannot set the name or password for group 0. 

After a Group command, the current settings for the group are displayed. Just the command 
"Group" lists all the initialized groups. 

Setting the password and name initializes the group if not already initialized. 

Any parameter not specified defaults to the current setting if the group has been initialized. 

Wildcards can be used in the snapshot list. 

A password, name or snapshot must be enclosed in quotes if it contains a comma or you want 
leading or trailing spaces. 

Setting the password to "" clears the group. There can be no other parameters on the line. 

The Active snapshot must remain a member of at least one group. 

Examples: 

To initialize group 1 to have the name "My Group", the password "pass1" and contain all 
snapshots that start with "Test": 

GROUP 1, pass1, My Group, Test*  
To have only the snapshots "Primary" and "Secondary" in the default group:  
GROUP 0,,, Primary, Secondary  
To change the password of group 1 to "frog5":  
GROUP 1, frog5  
To change the name of group 1 to "Test":  
GROUP 1,, Test  
To clear group 1:  
GROUP 1, ""  

IMPORT Command 

The IMPORT command provides a method of importing a snapshot from a file or set of files.  

The IMPORT command is used as follows: 
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IMPORT <file name> <snapshot name> [USER domain\user password]  
The <file name> is the full path name of the import file. Use double quotations when the file 
name contains spaces.  

The <snapshot name> is the name of the destination snapshot. If <snapshot name> does not 
exist, a new snapshot will be created. Wildcards (*,?) can be used to select an existing snapshot. 
Use double quotations when the snapshot name contains spaces. 

If the import file is on a network drive you will need to provide a user and password for access. 
Use the "USER" parameter or the USER command below. 

Example: 

To import the snapshot "Copy Primary" from the file E:\PrimaryBackup.arx: 

IMPORT E:\PrimaryBackup.arx "Copy Primary"  
To import the snapshot "Copy Primary" from the network location "\\TEST\DropBox":  
IMPORT "\\TEST\DropBox\Primary.arx" "Copy Primary" USER TEST\Tester password  

INFO Command 

The INFO command will provide a detailed reference to the snapshots and archives available on 
the system.  

The INFO command is used as follows: 

INFO <name>  
The <name> is the name of the snapshot or archive. Wildcards (*,?) can be used to select the 
snapshots or archives.  

If no names are specified, all the snapshots and archives are listed. 

Examples: 

To see the detailed information about a snapshot or archive named OEM Build: 

INFO "OEM Build"  
To see the detailed information on all the snapshots and archives starting with P:  
INFO P*  
To see the detailed information on all the snapshots and archives:  
INFO  
Sample Output:  
 
SNAPSHOTS: 
Snapshot Name:  Primary Snapshot  <Active> 
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Created On:     13-Sep-04 08:21AM 
Last Booted:    06-Oct-04 07:41AM 
Approx. Size:   N/A 
Description:    The primary system image created by the Installer. 
Snapshot Name:  Secondary Snapshot  <Frozen> 
Created On:     05-Oct-04 11:55AM 
Last Booted:    05-Oct-04 10:20PM 
Approx. Size:   1.68Gb 
Description:    The secondary system image created by Getting Started. 
ARCHIVES: 
Archive Name:   Archive of Primary Snapshot 
Created On:     27-Sep-04 11:26AM 
Total Size:     1.85Gb 
Size on Disk:   1.08Gb 
Unused Space:   0.00Gb (0%) 
Description:    The primary system image created by the Installer. 

INIT Command 

To create a new snapshot "slot," the INIT command can be used. The INIT command will create 
the structure needed to support a new snapshot. It does not remove or delete the active, or any 
alternate snapshots. It does not copy the operating system, application or data files. It would be 
used when installing a new version of an operating system...retaining the existing snapshot.  

The INIT command is used as follows: 

INIT <snapshot name>  
The <snapshot name> is the new name given to the new slot. The <snapshot name> must not 
exceed 35 characters.  

Examples: 

To create a new snapshot structure: 

INIT "My WinXP OEM Snapshot"  

INITC Command 

To create a new compressed snapshot the INITC command can be used. The INITC command is 
identical to the INIT command except that the new snapshot will be compressed.  

LIST Command 

The LIST command provides a quick list of the snapshots and archives available on the system.  

The LIST command is used as follows: 

LIST <name>  
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The <name> is the name of snapshots or archives. Wildcards (*,?) can be used to select the 
snapshots or archives.  

If no names are specified, all the snapshots and archives are listed. 

Sample Output: 

 
Snapshots: 
  *Primary Snapshot   (0)  13-Sep-04 08:21AM 06-Oct-04 07:41AM N/A 
  #Secondary Snapshot (1)  05-Oct-04 11:55AM 05-Oct-04 10:20PM   1.68Gb 
Archives: 
   Archive of Primary Snapshot           27-Sep-04 11:26AM    1.85Gb 

REMOVE Command 

To completely remove a snapshot, the REMOVE command can be used. The REMOVE 
command will delete all operating system, applications, data, and InstantRecovery structure files 
within the given snapshot. You cannot REMOVE the active snapshot.  

The REMOVE command is used as follows: 

REMOVE <snapshot name>  

Examples: 

To remove a snapshot named "OEM Build": 

REMOVE "OEM Build"  
At this point the removed snapshot is completely void of all operating system, applications, data, 
and InstantRecovery structure files. You will not see the snapshot list on the pre-Windows Boot 
screen, or the LIST / INFO commands.  

RENAME Command 

The RENAME command is used to rename a snapshot.  

Note: If a snapshot is being referenced from a scheduled event, renaming a snapshot may cause 
the event to fail. 

The RENAME command is used as follows: 

RENAME <source name> <destination name>  
The <source name> is the name of the snapshot to be renamed. Wildcards (*,?) can be used to 
select the snapshot. Use double quotations when the source snapshot name contains spaces.  
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The <destination name> is the new name of the snapshot. 

Examples: 

To rename snapshot "Primary", to "Secondary": 

RENAME Primary Secondary  
To rename snapshot "OEM Build" to "Test System":  
RENAME "OEM Build" "Test System"  
To rename snapshot "1. My Default Boot:" to "Test System":  
RENAME 1* "Test System"  

RESTORE Command 

The RESTORE command provides a method to restore an archive to a snapshot.  

The RESTORE command is used as follows: 

RESTORE <archive name> <snapshot name>  
The <archive name> is the name of the archive to restore. Wildcards (*,?) can be used to select 
the archive. Use double quotations when the archive name contains spaces.  

The <snapshot name> is the name of the snapshot to create or update. If <snapshot name> does 
not exist, a new snapshot will be created. Wildcards (*,?) can be used to select an existing 
snapshot. Use double quotations when the snapshot name contains spaces. 

Examples: 

To restore the archive "Archive of Primary" to "Copy of Primary": 

RESTORE "Archive of Primary" "Copy of Primary"  

SIZE Command 

The SIZE command will recalculate the size of an active or alternate snapshot. The 
InstantRecovery Service does not continuously calculate the size of the active snapshot. This 
would degrade your system performance. You can use this command when needed to update the 
approximate size calculations. However, alternate snapshot sizes are calculated after a COPY 
command, thus not requiring a SIZE. The SIZE command works on any snapshot.  

The SIZE command is used as follows: 

SIZE <snapshot name>  
The <snapshot name> is the name snapshot to be renamed. Wildcards (*,?) can be used to select 
the snapshot.  
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Examples: 

To SIZE snapshot "Primary": 

SIZE Primary  
To SIZE snapshot "1. My Default Boot:"  
SIZE 1*  

UNFREEZE Command 

The UNFREEZE command allows you to unfreeze your frozen snapshot and optionally remove 
the freeze storage.  

The UNFREEZE command is used as follows: 

UNFREEZE [clean]  
The optional parameter "clean" indicates that the freeze storage is to be removed.  

If you are updating your frozen snapshot, it may be better to disable the Pre-boot, make your 
changes and test them. This way, if you want to discard your changes and start over, you can 
simply enable the Pre-boot and reboot. When you are satisfied re-freeze the snapshot and enable 
the Pre-boot. 

USER Command 

The USER command sets the user and password for network EXPORT and IMPORT. The user 
and password are not saved so are only valid for the current session.  

The USER command is used as follows: 

USER <domain\\user> <password>  

VERIFY Command 

The VERIFY command turns OFF or ON the copy engine verify flag. The flag is not saved so it 
is only valid for the current session.  

The VERIFY command is used as follows: 

VERIFY [ON | OFF]  

Password-Protecting InstantRecovery 
The Manager and Command Line Interface (CLI) can be password protected. Once set 
the password will be required to run the Manager and the CLI.  
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To set a password use the CLI command: 

Config ManagerPassword <password> 
The password must be between 7 and 31 characters and is case sensitive. If a 
password has already been set you will be prompted to supply the current password 
before it can be changed.  

To remove the password use the command: 

Config ManagerPassword - 
In the CLI non-interactive mode (where the command is placed on the command line) 
the password must be supplied in an environment variable. The DOS command is:  

Set MANAGERPASSWORD=<password> 

Remote Controlling InstantRecovery 
You can control InstantRecovery on a remote computer using the command line 
interface.  
   
Remote Control of InstantRecovery installed on a remote computer using the 
command line interface is not available in InstantRecovery Home.  

Connecting: 

To control a remote computer, use the command: 

CONNECT <computer>[:<port>] [<user>] [<password>]  
Where <computer> is the name or IP address of the remote computer you want to 
control. For example: CONNECT Test  

If you want to override the default port number, enter colon (:) followed by the base port number 
to use. See note below. 

You will need to supply the name and password of a user with Administrator or Domain 
Administrator rights on the remote computer. If you don't enter them on the command line you 
will be prompted for them. If you are supplying a domain user, enter the user in the form 
domain\user. 

Controlling: 

While you are connected to the remote computer the prompt changes to the name of the remote 
computer (e.g. TEST>). 

All the commands you enter affect the remote machine not the local one. 
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Two commands are useful with remote control: 

BOOT [<snapshot>] - boots the specified snapshot. If no snapshot is specified it will 
reboot the computer. You are automatically disconnected. This command works in 
local mode also - beware.  

BATCH <file> - executes each of the commands in <file> in sequence. If any command in 
the file fails no more commands in the file are executed. You will need this command if you 
write remote scripts using ISRControl. 

Disconnecting:  

You can disconnect and return to your local machine by entering the command DISCONNECT. 
You can connect to another computer by entering another CONNECT command - you are 
automatically disconnected from the first computer. 

Notes: 

For remote control, InstantRecovery uses sockets bound to the ports 48288 and 48289. You can 
change port numbers by using the command: CONFIG RemotePortNumber [<port>] - Where 
<port> is the first of the two port numbers to use - the second is always <port>+1. 

To connect to a remote computer with a non-default port use :<port> following the computer 
name. For example: CONNECT Test:12345 

To disable remote control of a computer, set RemotePortNumber to zero. 

You do not have to have InstantRecovery installed on the local computer to control a remote one. 
Just put ISRControl.exe and ISRCopyCtrl.dll on the local computer and double-click 
ISRControl.exe. 

Disabling/Enabling the InstantRecovery Pre-boot 
Normally you will want to leave the InstantRecovery Pre-boot enabled, but there are 
times where you may wish to disable the Pre-boot. For example, if you are going to use 
a drive imaging program to make an image of your system disk, the Pre-boot must be 
disabled before the image is made otherwise the image may be unbootable.  

To disable the InstantRecovery Pre-boot, choose Actions>Disable Pre-boot from the menu: 
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The disable confirmation dialog will be shown: 

 

Click OK to disable the InstantRecovery Pre-boot. The Status will change to: 

 

You should re-enable the InstantRecovery Pre-boot as soon as possible. 

Updating InstantRecovery Software 
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Updating to a newer build of InstantRecovery requires several steps:  
   

1. Uninstall the existing build of InstantRecovery.  When prompted to Remove 
Program Only or Remove All, select Remove Program Only.  Warning: If you 
select Remove All during uninstall, all of your existing Recovery Snapshots will 
be deleted and you will not be protected until you create a new Recovery 

Snapshot.   
2. Install the new build of InstantRecovery.  After installation, when you next run 

InstantRecovery, you will see your existing Recovery Snapshots. 
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